2004 Quest speedometer issues

New Topics Forums General Discussion 2004 – 2009 Nissan Quest 2004 Quest speedometer issues

Tagged: ,

This topic contains 2 replies, has 3 voices, and was last updated by  Canada-Q2005 1 year, 7 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #10511

    bkcat2001
    Participant

    Greetings:
    New to the group. Bought a 04 Quest from an estate last year that only had 21K miles on it.
    Had the original tires that were dry rotted.
    Put new tires on, changed oil/filter, etc and have been very happy with it.
    Now have 25K miles but the speedometer has started to act up. Driving approx 30mph the speedo shows 60mph. Stop at a stop sign and it goes down to 30mph at a standstill and sticks there.
    Shut off now in my garage and the speedo still says around 30 mph. Tach, odo, gauges…. everything else seems fine. Any ideas would be much appreciated!
    Thanks……

    #11051

    Rosco6104
    Participant

    I have the same problem with my 2005, including the RPM doesn’t work properly either!

    #11071

    Canada-Q2005
    Participant

    First thing to check is the ECU body rot.
    ECU is under the plastic cover on the passenger side of the engine bay, right under the passenger windshield wiper.
    Pull the plastic carefully, do not break it, remove the ECU and check if its aluminium body has rotten.
    You may want to clean it, apply silicon heatsink compound onto the body and steel bracket, re-install and spray with Rust-check.

    If it is badly rotten with the through holes, you will need to replace the ECU.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.