Check Engine Light, runs rough, no code!

New Topics Forums General Discussion 1999 – 2002 Nissan Quest Check Engine Light, runs rough, no code!

This topic contains 6 replies, has 3 voices, and was last updated by  10000cars 7 years, 1 month ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1043

    email4kh
    Member

    2000 3.3L
    The CEL comes on as soon as I start the engine. The idle is rough, but I don’t see any change in RPM. With acceleration or under any load (even at constant speed on cruise control), the CEL starts flashing. Three different meters at two different places failed to get a code. With all three meters, the meter reads “WORKING,” but no code is produced, even after several minutes, engine running or not (but, since it’s idling, the CEL isn’t flashing).

    Would it help to run the car with the meter to get a code? I’ve cleaned the mass flow sensor.
    Any ideas?

    #4309

    thera
    Member

    Knock Sensor will NOT throw a code, try this, figure out where it is, Disconnect it and see if it makes a difference, or throws a code, if it does throw a knock sensor code u will know it is working, if after removing the harness it still doesnot throw a code its KS.

    #4310

    email4kh
    Member

    Thanks! I’ll certainly check it out. I was under the impression that the knock sensor was more of a “symptom indicator,” only there to send a code signal in the event of a knock or misfire. But, I didn’t think a bad knock sensor, itself, could cause these symptoms.

    #4311

    email4kh
    Member

    Found a different brand of OBD reader and it indicated the knock sensor and a cylinder misfire. Replaced the plug wires and it’s running fine.

    #4326

    email4kh
    Member

    .

    #4482

    email4kh
    Member

    I learned that many readers won’t get a code if there’s any accessory plugged into the cigarette lighter.

    #4608

    10000cars
    Participant

    PLEASE , on the code “P0325-Knock sensor 1 circuit malf( bank 1 or single sensor)”

    does somebody knows how to change the K-sen. Thanks so much. Ps it’s a 2000 3.0Litre

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.