Environmental controls do not light

New Topics Forums General Discussion 2004 – 2009 Nissan Quest Environmental controls do not light

This topic contains 5 replies, has 4 voices, and was last updated by  enangst 9 years, 5 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #301

    enangst
    Member

    2005 SE

    The environmental controls are only lit maybe 1-5% of the time when other console lights are lit. Dealer has replaced a switch controlling the lights and the problem remains the same.

    Has anyone else had this issue, and what was the solution. I am under warranty but the dealer seams to be scratching there heads on this one.

    #2491

    ssgtange
    Member

    First mine went out and now they came back on but all the dash lights now blink. I posted a forum too and will let uou know if I get it figured out.

    #2841

    kquest05
    Participant

    I have had trouble since 2006 and finally had the dealer look at it this month. They replaced the whole console and after 2 weeks it started to have the same trouble with the top 5 lights not lighting up for at least 20-30 minutes. They will now be ordering me a new dimmer switch. I only notice the lights not working when it gets cold outside. If it’s 50 or above they work just fine.

    kquest05

    #2862

    kquest05
    Participant

    I just had my van in the shop for the 3rd time and it seems to be working with the top 5 climate controls finally lighting up. It would only do it when the weather was under 35 degrees and only for 1/2 hour while the van was warming up could I not see them. They replaced the whole knob panel first, I’m not sure what they did the second time, and now they replaced the dimming switch. So far that seems to be working.

    I hope this helps.

    kquest05

    #2870

    brandowain
    Participant

    Funny…I noticed this same problem periodically in my 04 Titan!

    #2941

    enangst
    Member

    Thanks for everyone’s comments. Mine has something to do with the temperature as well. It is spring and they work again. I guess I will have to wait until next fall to have the dealer try something else.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.