Exhaust broke on the way to work today

New Topics Forums General Discussion 2004 – 2009 Nissan Quest Exhaust broke on the way to work today

This topic contains 3 replies, has 1 voice, and was last updated by  Canada-Q2005 7 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #11441

    Canada-Q2005
    Participant

    Was driving along on the highway, coasting in the right lane past the slowed down traffic, when there was a slight ‘pop’ and the engine sounded like Harley Davidson from that moment on.

    It will be lots of fun driving around like that until I get it fixed.

    At 110,000 miles and 11 years old she is still on the original exhaust everything – cats, mufflers, resonators and pipes. I am surprised it survived that long in Canadian salt.

    #11442

    Canada-Q2005
    Participant

    My mechanic looked at the exhaust and found that the O2 sensor bung’s thread completely rotted and the sensor popped out.
    I bought a bung on Amazon and will try to have it welded in.

    #11461

    Canada-Q2005
    Participant

    The mechanic mis-informed me. Actually the whole bung with the O2 sensor fell off. He welded it back in place but now every time I start and shut off the engine there are 3-4 sounds of backfiring: pop-pop-pop.

    #11501

    Canada-Q2005
    Participant

    Just for the info for anyone who may have the same problem, it fixed itself after 3 rides and total of 10 miles or so. “Service engine light” is off now, no backfiring and no codes anymore. Knock on wood!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.