Noise From Suspension

New Topics Forums General Discussion 1993 – 1998 Nissan Quest Noise From Suspension

This topic contains 2 replies, has 3 voices, and was last updated by  Quest Owner 9 years, 7 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #76

    hkj
    Member

    My van has had a very loud clunking noise coming from the front. I’ve had the struts and strut mounts replaced and also the lower control arm bushings (or so my tech says!!)…but the noise persists.
    My technician cannot find anything wrong but obviously something is amiss here. Anyone experience similar problems?

    #2821

    mmcpeck
    Participant

    I am having the same problem with my 93 Villager. I just replaced the struts last weekend, and I still have a pretty decent clunking in the front end, as well as a kind of creaking/scraping noise on bigger bumps and dips on both sides in the front.

    The struts I replaced were original and were shot, the van has 127K on it, so I am thinking the previous owner drove around with bad struts for so long that the rest of the front suspension took a beating. I was thinking of the control arms as well as the stabilizer could be the problem, I can only assume that all of the bushings are shot.

    The new struts had almost no effect on the noise. The whole front end sounds loose.

    Any experst know what could be wrong? Is this common on Quests/Villagers?

    Thanks.

    #2887

    Quest Owner
    Participant

    sometimes it can be the engine mounts. have your tech check the mounts for wear @ 127k it could be the mounts.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.