Unable to play burned DVD videos in 2006 Quest

New Topics Forums General Discussion 2004 – 2009 Nissan Quest Unable to play burned DVD videos in 2006 Quest

This topic contains 7 replies, has 7 voices, and was last updated by  russcarver 7 years, 4 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #614


    Hello, I have 2006 Nissan Quest with dual screen DVD player, it is paying Original DVDs fine, but unable to play burned DVDs and it is always showing disk error. Has any one ever experienced this issue and fixed it?



    Make sure you “finalize” the DVD after taping the show/movie. If you don’t the DVD will only play in the original DVD player.

    2004 Quest S



    Thanks for your reply. All my DVDs are finalized and they just play fine in every DVD player except Quest 🙁



    I have tried them all and I have had the best luck playing back video using Maxell -Rs. I get them from Wal-Mart. When you record on these blank DVDs, they seem to playback in most players. As the other poster recommended, you must “finalize” the DVD or it definitely will not work in other players.



    Is it the brand, or is it the format?

    skumar – Are you using DVD+R or DVD-R discs? Or -RW/+RW? My experience is that DVD-R discs work in more players than DVD+R discs, and RW discs are less likely to work. Please let us know if the Maxell DVD-R discs work for you.

    Northern Virginia

    2008 Nissan Quest S



    I have had this problem previously. The solution is to burn your DVDs with Region 1 coding. You might be burning your DVDs with no region coding which is preventing them from playing back.



    first off, make sure your using dvd-r and no dvd-rw will work. dvd-r is the old method of a burnt dvd. dvd+r is the current. i guarantee if you burn your movie and make sure it is finalized with the dvd-r discs it should be fine.



    I am having the same problme in my 2009 Quest. Has anyone solved it yet? I finally was able to create a “video” DVD (region to select was not an option in my software). It plays in all computers and DVD players I own but the Quest. I get a disc format error. I am using Sony DVD-R discs (single layer 4.7 GB capacity). The disc is finalized. FYI, UDF formatted discs don’t work either (but I didn’t expect them too as it is just an MPEG file on the disc then. But it would be nice…).

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.